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SEARCHING

Search for objects by text in the object body, author, keyword, note title, view title, problem, scaffold support, 
user group, date created, date last modified, unread, references to your notes, and, for editors and managers, 
status and accessibility. The initial criterion chosen will determine the remaining Search fields available. 

To perform a search:

1 . Check or uncheck the Notes, Views, Attachments, and Movies check boxes to indicate the Knowledge 
Forum objects to search for.

 2. Select the initial criterion from the first Search drop-down list.

 3. Select from the second Search drop-down list (if applicable).

 4. Either type the search term in the text field or select from the third drop-down list (if applicable).

5. Click Find. 
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From a view, click  to access the View List window.

 1. Click . The New View Link window appears.

 2. Select the view to link to from the Choose a view drop-down list.

CREATING A VIEW LINK

THE VIEW LIST

Click the check 
box to select 
the view link.

Click the view 
link to access 
the view.

Copy selected view links to My Hotlist or other views by using the Do Action drop-down list.

Select the type of views 
to display from the Show 
drop-down list.

To create a view link in a view:

Click to create a new view.

Increase the  
number of  
search criteria to 
narrow the search.

Set notification in 
order to receive  
e-mail with updated 
search results.

Saved searches 
listed for future use.

Save search criteria.
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SIGNING ON

To log into Knowledge Forum: lite version:

  1. Type your Knowledge Forum URL address in your browser in the format: 
  http://yourmachinename:port#/kforum   
The “Welcome to Knowledge Forum” window appears  
along with a KnowledgeForum.jnpl downloaded to your computer.  
For your next log-in, you can either type URL address in your  
browser again or double-click the KnowledgeForum.jnpl. 

 2. Select a language from the Language drop-down list.

 3. Select a database from the Databases drop-down list.

 4. Type your username in the Login field.

 5. Type your password in the Password field.

 6. Click Login.

Knowledge Forum opens to a view.

A VIEW

Toolbar 
See below.

Movie 
Double click 
to open.
Attachment 
Double click 
to open.

Note 
Double click to 
read note.

View Title
View Link 
Double click to go 
to view.

 L i t e 

THE TOOLBAR

New Note 
To create a new note

Logout 
To exit Knowledge Forum

Help 
To get online help

View Headings 
Highlight and 
organize selected 
objects.

Links Shows build-on or 
reference links.

Info
About the view.

Note: In the lite version, you can not add authors, groups, or additional scaffolds. You should use the Basic or Enhanced version to set-up 
your database and then your users can use the lite version to add their ideas to the database.

View Finder 
To find or create a view

Search 
To search the database

Workspace 
To access your Workspace

Assessment Tools 
Available if tools have been added 

Show/Hide Palette  
To show or hide the drawing palette

Although the  
toolbar appears 
on every view, 
some buttons 
might not be 
available to you 
depending on 
your user type.



CONNECTING IDEAS

ATTACHMENTS MOVIES

To add an attachment to a view:

 1. Click . The New Attachment  
window appears.

 2. Type the title in the Title field.

 3. Click Choose File. The Open  
window appears.

 4. Select the file to attach.

 5. Click Choose. 

 6. In the New Attachment window, select the 
view to add the attachment to.

 7. Click Close and Contribute.

To add an existing movie to a note:

 1. Select a movie from the Movie drop-down 
list in the Reference section.

 2. Click Close and Contribute.

To add a new movie to a note:

 1. Select Create new movie from the Movie 
drop-down list in the Reference section. The 
New Movie window appears.

 2. Complete the New Movie window.

 3. Click Close and Contribute to save the note.

In addition to referencing, you can connect ideas in 
Knowledge Forum using several different methods.

Rise-Above Note 
From a view, check the notes you want to rise above 
(including notes from other users) and select New 
Rise-Above from the Do Action drop-down list. 
Complete the creation of the new rise-above note.

Build-On Note 
In read mode, click Build-on in the note you want to 
build on. Complete the creation of the build-on note.

Co-Authors 
In advanced mode, add or remove authors from the 
Authors section of the note.

Publish 
In advanced mode, click the Candidate for 
Publication check box.

Annotate 
In read mode, click Annotate and type your annotation 
in the Annotation field of the New Annotation window.

To add an existing attachment to a note:

 1. Select an attachment from the Attachment 
drop-down list in the Reference section. 

 2. Click Close and Contribute.

To add a new attachment to a note:

 1. Select Create new attachment from the 
Attachment drop-down list in the Reference 
section. The New Attachment window 
appears.

 2. Complete the New Attachment window.

 3. Click Close and Contribute to save the note.

Attachment drop-down list

To add a movie to a view:

 1. Click . The New Movie window appears.

 2. Type the 
title in the 
Title field.

 3. Click 
Choose 
File next 
to the File field. The Open window appears.

 4. Select the movie file to attach.

 5. Click Choose. 

 6. In the New Movie window, select the view to 
add the movie to.

 7. Select the playback option.

 8. If you want to add a poster frame:

  Click Choose File next to the Poster frame.  
The Open window appears.

   Select a .jpg file to associate with the  
 movie. Click Choose.

 9. In the New Movie window, click Close  
and Contribute.                            
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ATTACHMENTS AND MOVIES

CREATING A NOTE

 1. Click . The New Note window appears.

 2. Complete the basic note features. You do not need 
to use every feature when creating a note. The 
basic note features consist of the note contents, 
problem, scaffolds, and keywords. 

 3. In the File menu, select Save. You will be  
prompted for a title for the note and you can 
select the view in which this note will appear.  

The note icon will be added to the view and the note 
window will remain open.

After the note has 
been saved this will 
highlight. Click to  
create a build-on note.

Click to access 
pull-down menus.

Type in keywords.Use keyword tool to 
select keywords in 
note contents.

Shows connections to 
other notes and views.

Shows authors and allows 
you to add co-authors.

Type  
content. 
Arrange  
movies,  
attachments, 
notes, and 
views by 
dragging 
and  
dropping.

  Add scaffold  
  supports:

 • Select a  
scaffold from 
the Scaffolds 
drop-down list. 

 • Select a  
scaffold 
support by 
double-clicking 
the support, or 
click the  
Add button.   

Click to create  
an annotation.

Type the  
problem.

Click to insert 
drawing in note.

To add movies and attachments (other documents or images) is to drag them from your desktop to a  
Knowledge Forum view or note. An image (jpg, png, or gif) can be displayed as an image by using the  
Objects pull-down list on the note or view and selecting Show in Place. 



CREATING A NOTE

 1. Click . The New Note window appears.

 2. Complete the basic note features. You do not need  
to use every feature when creating a note. The 
basic note features consist of the Title, In View, 
Scaffold, Content, Reference, Keywords, and 
Problem sections. 

 3. Click Advanced to access the advanced note 
features. You do not need to use the advanced 
features to create a note. In advanced mode, 
you can add co-authors, hide or display image 
attachments, and nominate a note for publication.

 4. Click Close and Contribute.

The note appears in read mode as it is added to 
the view.

Type the note’s title.

Select the view to 
add the note to.

Type the problem.Type the keywords.

Click to access the advanced note features. Click to save the note and close the window.

Select a note, 
view, attachment, 
or movie to  
reference from 
the corresponding 
Reference drop-
down list.

Type content.

Add scaffold supports:

 • Select a scaffold 
from the Scaffolds 
drop-down list. 

 • Select a scaffold 
support from the 
Scaffold list box. 

 • Click Add. 

 • Type the scaffold 
support text in 
the Content field 
between the > 
< symbols of the 
scaffold support’s 
HTML code.

REFERENCING
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Whole Note 
Select the note to reference from the Note drop-down 
list in the Reference section of the referencing note.

Part of a Note (Quoting) 
Open the referenced note and copy and paste the 
text you wish to quote between the > < symbols in 
the Content field of the referencing note.

View 
Select the view to reference from the View drop-down 
list in the Reference section of the referencing note.

Web Page 
Type the Web link in http:// format in the Content field 
of the note.

Movie Segment 
Open the movie. Set the start and end points of the 
movie segment and click Produce Movie Segment. 
Copy the movie segment’s HTML code into the 
Content field of the referencing note.

HTML code for each reference will be added to the 
Content field of your note.
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CONNECTING IDEAS

Build-On
Open a saved note and click the  button on the bottom of the note.  

A build-on note will open. Add your ideas. When you save the build-on note,  

it will be connected to the note it was built on.  

Co-Authors
If you are an author of a note, click the  tab on the top of the note. Add or remove authors to  
this note. 

Annotate

Open a saved note and click the  button on the bottom of the note.    

An Annotation window will open. Type in your annotation. When you close and  

save it an Annotation icon  followed by the name of the author will appear in  

the note. 

Rise-Above

From a view, select the notes you want to rise above (including notes from other users) and select  

Rise-Above from the Objects pull-down list. A rise-above folder will appear in the note containing the 

notes that were selected. Complete the creation of the new Rise-Above note.

Referencing
A Whole Note 
Drag and drop the note icon to reference into the content of the referencing note.

A Part of a Note (Quoting) 
Open the referenced note and copy the text you wish to quote, then paste into the content of the  
referencing note.

A View 
Drag and drop the view icon to reference into the content of the referencing note. 

A Web Page 
Type the Web link in http:// format in the content of the note.

WORKSPACE

Your Workspace is a private space where you can create and edit notes, work on a drawings, add  
attachments or movies that are only accessible by you. When you are done working on your ideas, you can 
add them to a view to make them accessible to the community by dragging and dropping them from your 
workspace to a view. 

DRAWINGS

The Palette button shows and hides the drawing palette. Use this  
palette to create a drawing in a view or a note. 

You can also drag and drop a jpg, png, or gif from your desktop to a  
view or note, then use the Object pull-down list to Show in Place. 
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SIGNING ON To log on to Knowledge Forum:

 1. Type your Knowledge Forum URL address in http://yourmachinename:port#/ 
format in your browser. The “Welcome to Knowledge Forum” window appears.

 2. Select a language from the Language drop-down list.

 3. Select a database from the Database drop-down list.

 4. Choose the UI Mode, Basic, to match this Quick Reference section.

 5. Type your username in the Username field.

 6. Type your password in the Password field.

 7. Click Sign On.

Knowledge Forum opens to a view.

A VIEW

Toolbar 
See below.

Movie 
Click to open.

Attachment 
Click to open.

Note 
Click to read note.

Select option for 
displaying notes in 
the view.

The Do Action drop-
down list allows you to 
move or clear selected 
objects, and create 
headings.

View Title

View Link 
Click to go to view.

 B a s i c 

THE TOOLBAR

New View Link 
To add a view link to a view

New Note 
To create a new note

New Attachment 
To add an attachment to a view

Scaffolds 
To view, add, or edit scaffolds

Authors  
To view, add, or edit authors, 
groups, and registration codes

Search 
To search the database

New Movie 
To add a movie to a view

View List 
To find or create a view

Workspace/Reader 
To access your Workspace

Logout 
To exit Knowledge Forum

Assessment Tools 
Available if tools have been added 

Help 
To get online help

View Headings 
Highlight and 
organize selected 
objects.

Picture 
Click to open.
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SEARCH

Search for objects by words, author, title, keyword, date modified or date created. 

To perform a search:

 1. Check or uncheck the Notes, Views,   
Attachments, Movies and Drawings  
check boxes to indicate the  
Knowledge Forum objects to search for.

 2. Select the criterion from the Search  
drop-down list.

 3. Type the search term in the text field.

 4. Click Search.

THE VIEW FINDER

 1. From a view, click  to access the View Finder. 

 2. Type in the name of the view you want to find or  

click .

 3. Drag and drop from the View Finder to a view to  
create a view link.

Creating a New View

 1. In the View Finder, go to the File pull-down list and select New View. 

CREATING A VIEW LINK

To create a view link in a view:

 • Drag a view icon from the View Finder to a view or from a view to a note. 

Although the  
toolbar appears 
on every view, 
some buttons 
might not be 
available to you 
depending on 
your user type.
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•  Q U I C K  R E F E R E N C E  C A R D  •

SIGNING ON
To log on to Knowledge Forum:

 1. Type your Knowledge Forum URL address in http://yourmachinename:port#/ 
format in your browser. The “Welcome to Knowledge Forum” window appears.

 2. Select a language from the Language drop-down list.

 3. Select a database from the Database drop-down list.

 4. Choose the UI Mode, Enhanced, to match this Quick Reference section. 

 5. Type your username in the Username field.

 6. Type your password in the Password field.

 7. Click Sign On.

Knowledge Forum opens to a view.

A VIEW

Toolbar 
See below.

Movie 
Double click 
to open.
Attachment 
Double click 
to open.

Note 
Double click to 
read the note.

View Title
View Link 
Double click to go 
to the view.

 e n h a n c e d 

Although the  
toolbar appears 
on every view, 
some buttons 
might not be 
available to you 
depending on 
your user type.

THE TOOLBAR

New View Link 
To add a view link to a view

New Note 
To create a new note

New Attachment 
To add an attachment to a view

Scaffolds 
To view, add, or edit scaffolds

Authors  
To add, or edit authors and groups. 

Search 
To search the database

New Movie 
To add a movie to a view

View Finder 
To find or create a view

Workspace 
To access your Workspace

Logout 
To exit Knowledge Forum

Assessment Tools 
Available if tools have been added 

Help 
To get online help

View Headings 
Click to edit title. 
Drag and drop 
objects to add  
to heading,

Links Shows build-on or 
reference links.

Info
About the view.

Menu options
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SEARCH

Search for objects by words, author, title, keyword, date modified or date created. 

To perform a search:

 1. Check or uncheck the Notes, Views,   
Attachments, Movies and Drawings  
check boxes to indicate the  
Knowledge Forum objects to search for.

 2. Select the criterion from the Search  
drop-down list.

 3. Type the search term in the text field.

 4. Click Search.
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THE VIEW FINDER

 1. From a view, click  to access the View Finder. 

 2. Type in the name of the view you want to find or  

click .

 3. Drag and drop from the View Finder to a view to  
create a view link.

Creating a New View

 1. In the View Finder, go to the File  pull-down list and select New View. 

Attachment: Image
Shown in place.

Show/Hide Palette  
To show or hide the drawing palette.

CREATING A VIEW LINK

To create a view link in a view:

 • Drag a view icon from the View Finder to a view or from a view to a note.

 or

 1. Click . The New View Link window appears.

 2. Select the view to link to from the Choose a view drop-down list.



CONNECTING IDEAS

ATTACHMENTS AND MOVIES

Build-On
Open a saved note and click the  button on the bottom of the note.  

A build-on note will open. Add your ideas. When you save the build-on note,  

it will be connected to the note it was built on.  

Co-Authors
If you are an author of a note, click the  tab on the top of the note. Add or remove authors to  
this note. 

Annotate

Open a saved note and click the  button on the bottom of the note.    

An Annotation window will open. Type in your annotation. When you close and  

save it an Annotation icon  followed by the name of the author will appear in  

the note. 

Rise-Above

From a view, select the notes you want to rise above (including notes from other users) and select  

Rise-Above from the Objects pull-down list. A rise-above folder will appear in the note containing the 

notes that were selected. Complete the creation of the new Rise-Above note.
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CREATING A NOTE

 1. Click . The New Note window appears.

 2. Complete the basic note features. You do not need 
to use every feature when creating a note. The 
basic note features consist of the note contents, 
problem, scaffolds, and keywords. 

 3. In the File menu, select Save. You will be  
prompted for a title for the note and you can 
select the view in which this note will appear.  

The note icon will be added to the view and the note 
window will remain open.

After the note has 
been saved this will 
highlight. Click to  
create a build-on note.

Click to access 
pull-down menus.

Type in keywords.Use keyword tool to 
select keywords in 
note contents.

Shows connections to 
other notes and views.

Shows authors and allows 
you to add co-authors.

   Add scaffold  
   supports:

 • Select a  
scaffold from 
the Scaffolds 
drop-down list. 

 • Select a  
scaffold 
support by 
double-clicking 
the support, or 
click the  
Add button.   

Referencing
A Whole Note 
Drag and drop the note icon to reference into the content of the referencing note.

A Part of a Note (Quoting) 
Open the referenced note and copy the text you wish to quote, then paste into the content of the  
referencing note.

A View 
Drag and drop the view icon to reference into the content of the referencing note. 

A Web Page 
Type the Web link in http:// format in the content of the note.
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Click to create  
an annotation.

Type the  
problem.

Click to insert 
drawing in note.

 The easiest way to add movies and attachments (other documents or images) is to drag them from 
 your desktop to a Knowledge Forum view or note. An image (jpg, png, or gif) can be displayed as an 
image by using the Objects pull-down list on the note or view and selecting Show in Place. 

You can also add an attachment or movie using the  or  buttons on the toolbar.  

To move an existing attachment or movie to a different view or note:

 1. Use copy and paste from the File menu to copy the attachment and paste it in the new view or note. 

 or

 2. Drag and drop an attachment or movie icon from a view or note into the content field of your note.

WORKSPACE

Your Workspace is a private space where you can create and edit notes, work on a drawings, add  
attachments or movies that are only accessible by you. When you are done working on your ideas, you can 
add them to a view to make them accessible to the community by dragging and dropping them from your 
workspace to a view. 

DRAWINGS

The Palette button shows and hides the drawing palette. Use this  
palette to create a drawing in a view or a note. 

You can also drag and drop a jpg, png, or gif from your desktop to a  
view or note, then use the Object pull-down list to Show in Place. 

Type  
content. 
Arrange  
movies,  
attachments, 
notes, and 
views by 
dragging 
and  
dropping.


